Прокидання портів на роутер Мікротик (Mikrotik)

Прокидання портів на роутер Мікротик (Mikrotik)

Технология, которая с помощью маршрутизатора позволяет наладить связь-обращение из Интернета к компьютеру по внутренней сети, называется проброс. Ее внедрение актуально, если есть необходимость организовать перенаправление трафика для многопользовательских игр, создаете оверлейные сети с равными правами для всех пользователей или делаете сервер с доступом к Интернет на локальном компьютере.

Практическому внедрению этой технологии с помощью роутера MikroTik посвящена статья.

Суть проброса состоит в перенаправлении порта. Это действие предполагает гармонизацию роутерного порта на внешнем интерфейсе с портом устройства, подключенного к сети. Эта процедура завязана на механизме NAT, отвечающего за трансляцию сетевых адресов.

Проще говоря этот механизм позволяет подключаться нескольким единицам оборудования локальной сети (ноутбукам, ПК, планшетам, смартфонам) к WAN-порту.

Рассмотрим работу этого механизма и отладку проброса на примере роутера MikroTik. Цель перенаправления — дать доступ цифровой видеокамере, работающей по IP-протоколу (IP-адрес устройства — 192.168.88.252, веб-интерфейс синхронизирован с 50 портом).

Обязательное условие настройки такого механизма на роутере MikroTik — наличие публичного, глобального, внешнего IP — белого адреса. Потому что именно они маршрутизируются в Интернете.

Чтобы проверить эту опцию, в меню откройте вкладку IP — Cloud, поставьте отметку DDNS Enabled и активируйте Apply. В строке статус должно отобразиться "updated". Это означает, что у роутера есть публичный адрес.

Если в этой строке написаны данные, которые указывают на ошибку, тогда адрес частный. Изменить серый адрес на белый может только провайдер. Так что без него не обойтись.

После проверки установлено, что маршрутизатор имеет белый IP-адрес — 178.189.224.121, а подсеть прописана так — 192.168.88.0/22. Задача — сделать так, чтобы при запросе адреса в браузере http://178.189.224.121:50000 активировались данные веб-камеры.

Примечание. 50000 — условное значение. Его лучше выбирать в диапазоне от 49152 по 65535.

Приступаємо до перенаправлення трафіку з відеокамери з IP-адресою до Інтернету. Для цього в налаштуваннях роутера в меню відкрийте вкладку New Terminal і послідовно додаємо такі команди:

  1. Для підмережі — правило маскарадингу — 192.168.88.0/22:

/ip firewall nat add action=masquerade chain=srcnat src-address=192.168.88.0/22

  1. Перекидайте запити з Інтернету до порту 50000 на внутрішню мережу — 192.168.88.252 та 50 (IP камери та дані порту, до якого вона підключена).

/ip firewall nat add action=netmap chain=dstnat dst-port=50000 in-interface=ether1 protocol=tcp to-addresses=192.168.88.252 to-ports=50

  1. Переключіть запити з локальної мережі до роутера 178.189.224.121 та порту камери 50000 на адресу камери (192.168.88.252) та порт у роуторі, до якого вона підключена. Таким чином, запити не будуть йти в Інтернет.

/ip firewall nat add action=netmap chain=dstnat dst-address=178.189.224.121 dst-port=50000 in-interface=bridgeprotocol=tcp src 192.168.88.0/22 to-addresses=192.168.88.252 to-ports=50

Щоб перевірити результати, відкрийте вкладку NAT  меню IP — Firewall. Коли відкриваєте у браузері потрібну адресу — http://178.189.224.122:50000, відкриється сторінка веб-пристрою з усіма опціями налагодок після введення імені користувача та його пароля.

Щоб синхронізувати веб-обладнання з планшетом (переглядати відео), рекомендуємо використовувати утиліту VLC media player. Її підтримує спеціальний протокол маршрутизатора TP-Link — RTSP. Використовуючи порт 554.

Щоб прокинути його на MikroTik, зробіть такі записи в налаштуваннях:

  1. /ip firewall nat add action=netmap chain=dstnat dst-port=554 in-interface=ether1 protocol=tcp to-addresses=192.168.88.252 to-ports=554
  2. /ip firewall nat add action=netmap chain=dstnat dst-address=178.189.224.121 dst-port=554 in-interface=bridgeprotocol=tcp src-address=192.168.8ad. 192.168.88.252 to-ports=554

Запускайте на планшеті потрібну програму, вибирайте «Мережевий ресурс», вводіть логін, пароль та зовнішню адресу роутера. Зображення буде доступним.

Зважте на ці нюанси при налаштуванні різного обладнання в мережі  для перенаправлення вивантаження та завантаження даних.